Results 1 to 9 of 9
  1. #1

    Exclamation Issues after Windows 10 Fall Creators Update

    After updating Windows 10 and the NVIDIA graphics drivers the following issues occur:

    • Disappearing and reappearing HUD elements as described in this reddit thread
    • Reproducible crashes for ALT-Tabbing out of PS2 (crashes 100%)


    Things I tried to fix the issue

    • Running everything in administrator mode (did this one regardless of the problem)
    • Running everything without administrator mode
    • Running everything with disabled fullscreen optimization
    • Disabled game mode (Windows 10 DVR)
    • No GeForce experience installed
    • Windowed / Fullscreen Windowed / Fullscreen doesn't make a difference
    • Recursion Legacy Hooks
    • Recursion Beta Participation


    I attached a cut version of my dxdiag.txt


    Thanks for the help!
    Attached Files Attached Files

  2. #2
    Stat Tracker Development Team
    Recursion Member
    Silencer's Avatar
    Join Date
    Feb 2014
    Location
    Chandler, Arizona
    Posts
    501
    Update: We can authenticate new builds against BattlEye now and I think I've found the problem we're having with the creators update. Currently working on a fix.

  3. #3
    Stat Tracker Development Team
    Recursion Member
    Silencer's Avatar
    Join Date
    Feb 2014
    Location
    Chandler, Arizona
    Posts
    501
    Update published to our beta branch. Please go to tools -> options -> beta pariticipation
    Then help -> update.

    This should resolve all of these problems.

  4. #4
    I came to chime in that I'm on and have been on the beta branch for the entirety of the time I've used Recursion and I'm on the 0.11.0.900 Beta currently experiencing a myriad of issues that I finally tracked down to Recursion Overlay.

    The program can be running without the overlay with no issue, but when the overlay is running I crash when starting Planetside, when I start Recursion after Planetside and its coupled with MAJOR performance loss I can't even begin to explain.

    I was completely baffled logging on playing getting 30-35 FPS in a 48-96 Amp station fight when I typically get 60-70 min FPS on a i7@4.7ghz/1080/1TB SSD. I went through process of elimination on overlays with the Steam Overlay, RTSS, and Recursion and finally once the stat tracker in-game overlay was disabled my FPS returned to normal, and crashes stopped happening.

    Going to mention I'm also running Windows 10 Fall Creators update with the most recent updates as of my post. I also would crash from alt-tabs, this is all recent and on the beta branch as when I saw this post I went to move over to the beta branch and realized - I'm already on it! I've had no such luck.

    Edit: Going to try a fresh install of the stat tracker and see how that fares.... Edit #2: Just results in the same issues of crashing in-game and at startup so for now I'm just gonna disable the overlay.

    I kind of figured it was Battleeye for some reason since nothings changed with my setup but I run RTSS/Recursion everytime I play.
    Last edited by Doom721; 01-02-2018 at 07:07 AM.

  5. #5
    Stat Tracker Development Team
    Recursion Member
    Silencer's Avatar
    Join Date
    Feb 2014
    Location
    Chandler, Arizona
    Posts
    501
    That performance hit shouldn't happen at all... Have you tried disabling the Creators update's full screen optimizations on PS2? Right clicking on the PS2 shortcut - properties - compatibility - disable full screen optimization. There's a chance that's interfering and causing a performance hit for us.

    Can you try disabling the geforce experience / shadow play if you run that to see if that's somehow causing a problem with us?

    One last debugging tip, you can turn on Impact Debug Display under RT display options. It will give an estimate of how much cpu time our overlay is taking up from PS2. Having it on actually lowers performance slightly since it's doing additional profiling and text display. (The number really shouldn't go above 5% and that's pretty high) but in your case I'm interested since you're getting a 50% performance impact at those amp stations.

  6. #6
    I'll try out the full screen optimizations, I actually played for a very long time testing/fiddling with this and found that I can in fact run Shadowplay with no performance loss and still reach high frame rates I'm used to ( 60+ in 48+ battles, 120+ in empty spaces ) So I don't think Shadowplay is the issue.

    The strange thing is I don't think the impact is exactly from the stat tracker itself, I think its from Planetside or Battleye, because I noticed the stat trackers impact is miniscule and never exceeds more than a few percent of CPU usage at best.

    I actually double checked and I've had Disable Full Screen Optimizations checked the entire time, along with the game and all the Battleeye executables set to admin privileges.

    Could the legacy hook have anything to do with it? Typically I've left it on because the overlay wouldn't run without it. I'm about to get back to fiddling with this because I honestly miss the overlay when playing and I can run the game fine with the stat tracker in the background, any of my issues were only when the overlay was enabled.

    Edit: Immediately getting issues with the overlay enabled. Alt-tabbing causes the game to crash to a G-12 error on their website, all before I had even selected a character ( was adding one to my tracking list alt tabbing, crashed each time I tabbed out )

    I've disabled legacy hooks, and I do not have Shadowplay on.

    Edit2: I can't alt tab with the overlay on without getting a G-12 error its kind of hard to track the performance issue of it since it seems to be a degradation over time, but really, not being to alt tab at all is my current issue ( and was part of the whole issue for really )'

    Usage seems to be a non issue 128mb of memory and CPU usage on the overlay sat at 0.0% usage saying RTST 0.00% | ES for the time I was in a small fight.
    Last edited by Doom721; 01-24-2018 at 08:40 AM.

  7. #7
    Name:  Untitled.png
Views: 258
Size:  73.6 KB

    I think I may have found my issue with 0.11.0.900 Beta and alt-tab crashing, not sure if its related to my previous performance because I can't seem to reproduce the issues I was having.

    So earlier I mentioned the RTST overlay debugger saying it had 0% usage, and on alt-tab I would crash out of the game to a G-12 error whilst trying just about everything you'd think to try. ( Fullscreen optimizations, disabling anything that could possibly hook into the game, controller related software, firewalls, malware scans, restarting, disabling steam overlay/shadowplay )

    I went to RivaTuner Statistics server and turned on Custom Directed3D Support and the first thing I noticed is that the translucency of the overlay and my overlay from RivaTuner had kind of "merged together" and my FPS overlay was behind RTST, and the debugger was now showing usage of 3-4% spiking to 5% CPU usage. Frame rate was not bad, in areas I tested, and I was successful able to stop the crashing. I also did happen to turn on Stealth Mode on the RivaTuner overlay, not sure if that is related.

    TLDR If you are running RivaTuner, enable Custom Direct3d support, and Stealth Mode and see if the results of alt-tab crashing changes.

  8. #8
    Found the performance issue, appears Nvidia share is hogging logical core 0/logical core 1 and causing my CPU to max out even at 4.7ghz, not related to Recursion.

  9. #9
    Stat Tracker Development Team
    Recursion Member
    Silencer's Avatar
    Join Date
    Feb 2014
    Location
    Chandler, Arizona
    Posts
    501
    Thank you so much for taking the time to troubleshoot and write this up. It's interesting to note the "ES" information on our impact debugger. That means we can't hook the normal D3D call we would prefer to (Present) and instead fall back on another. (End Scene -- "ES") This should only occur in the case of another program interfering such as FRAPS, or in this case RivaTuner. This is incredibly useful to know. Thank you for reporting this again and I'm glad your problem has been resolved.

    Oh and ideally Legacy Hooks off is better, faster, and more compatible with other software.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •