Results 1 to 6 of 6

Hybrid View

  1. #1

    Recursion overlay freezes after a while

    After long moments of inactivity overlay stops working, almost as if it goes into some kind of sleep mode. If i alt tab to the program itself everything works except session timer which is frozen too.
    Eventually it starts working again after i've pressed the overlay hotkey or alt tabbed.
    If i press the overlay hotkey very often it never freezes. Only freezes if i haven't pressed the hotkey in a while.
    Seems to freeze sooner when performance is lower (big battles).
    Not a recent problem, had it for a long time.

    I wanted to try legacy hook but that crashes the game.

    i7 7700HQ
    GTX 1050
    16GB RAM
    Game and Recursion on SSD
    Last edited by CptLegshot; 04-06-2021 at 10:59 AM.

  2. #2
    Recursion Member
    ashley's Avatar
    Join Date
    May 2015
    Location
    433 Eros
    Posts
    149
    Sounds like some kind of misconfigured or overly aggressive power saving thing most likely. Have you done any tweaks to "background app" power usage or other power savings features on your PC?

  3. #3
    Quote Originally Posted by ashley View Post
    Sounds like some kind of misconfigured or overly aggressive power saving thing most likely. Have you done any tweaks to "background app" power usage or other power savings features on your PC?
    I've done the opposite a long time ago, disabled all power saving and turned everything to max performance but i'll take a look.
    The odd thing is that it's only the overlay+session timer part of Recursion freezing, all other background programs like Discord, nvidia fps overlay and MSI afterburner with rivatuner overlay don't freeze.

  4. #4
    Weird that only this application is slow, maybe try reinstalling?

  5. #5
    Need more testing but seems like i've fixed the problem.

    Run gpedit.msc
    Computer Configuration -> Administrative Templates -> System -> Troubleshooting and Diagnostics -> Windows Resource Exhaustion Detection and Resolution
    Set to disabled

    I guess it's because i'm not running a normal version of win 10 and it's configured different by default.

  6. #6
    Quote Originally Posted by CptLegshot View Post
    Need more testing but seems like i've fixed the problem.

    Run gpedit.msc
    Computer Configuration -> Administrative Templates -> System -> Troubleshooting and Diagnostics -> Windows Resource Exhaustion Detection and Resolution
    Set to disabled

    I guess it's because i'm not running a normal version of win 10 and it's configured different by default.
    Thank you so much for describing the solution!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •