Results 1 to 9 of 9
  1. #1

    Overlay blocked by BattleEye

    Hello Recursion Team,

    i have been using Recursion since ~3 Months and really don't want to miss out on it anymore. After the BattleEye update, Planetside2/BattleEye is blocking the Overlay on startup
    (Blocked loading of file: "D:\Program Files (x86)\Recursion\RecursionTracker\rtst_d3doverlay_x 64.dll".).
    Tracking of stats and Voicepacks are still working fine, aswell as the Nividia Capture Overlay. I would like to ask if there are any possibilities on my side to fix this issue.

    Things i have tried so far:
    Using the legacy hook
    Using Auto/x64/x86 Overlay
    Starting Recursion and Planetside 2 in any possible Startup/Admin order
    Disable all other Overlay as well as Rainmeter

    i searched around the Web a little and couldn't find any other Threads regarding this, but i would be happy to be proven wrong.

  2. #2
    I'm running everything RTST without issues.

    I have RTST, Launchpad, and Planetside2_x64 set to run as admin from compatability tab of each .exe.
    Planetside2 is running full screen. I believe legacy hooks in RTST is disabled from the options menu.
    Last edited by McRory; 10-25-2016 at 05:54 PM.

  3. #3
    Thanks for the reply.
    Whats is your loadup Order, have you set the new Exe(PlanetSide2_x64_BE) to admin as well?
    Do you get something like the picture as well?Name:  Capture.PNG
Views: 2111
Size:  8.9 KB

  4. #4
    No I did not set it manually, I hadn't even considered it.

    But the launchpad launching as admin will launch ps2 as admin also.

    I first start gpuz-sensors, task manager-performance, real temp, and sometimes obs studio. On a second monitor.
    Then I start RTST and then Luanchpad/PS2.

    I don't even notice a battleeye window. But I've been using battleeye for a long time since arma 2 release. So the battleeye service was already running on my PC.

    I guess another thing to note is I have the beta option checked in RTST.
    Last edited by McRory; 10-25-2016 at 11:31 PM.

  5. #5
    So I double checked and started my game. No Battleeye window at all, and the crosshair overlay is showing.

    First section of the Battleeye FAQ specifically mentions your BE message.

  6. #6
    I worked through the FAQ but the problem persits, the message doesn't show if i use the x86 Overlay, but it would not show an Overlay ingame as well. As soon as i switched to the x64 Version the window pops up.
    I am using the beta branch as well.
    I reinstalled Recursion now, before switching to the beta branch,the Hook launcher Console didnt worked corectly and stated it could not find the vTable(whatever that means)
    as well as that "Failed compatibility test. RTST should be started prior to launching PS2." even tho PS2 was not even running
    On the beta the same Problem as above occurse.
    Thanks for the help this far btw
    Last edited by BadAndMad; 10-26-2016 at 12:54 AM.

  7. #7
    Recursion Member
    ashley's Avatar
    Join Date
    May 2015
    433 Eros
    I'm not sure what the issue is here. Battleye shouldn't be blocking any RTST components, and it all works fine for me. Have you tried contacting Battleye themselves?

  8. #8
    I was not home for the last three days, i am gonna contact them now and report back if we can find a fix for the issue.

  9. #9
    Okay after a quick chat with the servie from Battleye i was able to solve the problem. I have kind of a second Firewall installed, which i did not recognize as one, because this Firewall blocked the Battleye Services , they blcoked the Overlay.

    The solution were the Ports:
    UDP ports 20066-20068
    to the IP:

    Thanks to all of you for your help
    Last edited by BadAndMad; 11-01-2016 at 12:29 PM. Reason: Found the solution

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts